MSSQL linked server transaction "MSDTC XARMCreate error".

More
13 years 3 months ago #730 by ktoss

So the best solution is to configure it...

Ok, but how should I do this? I have dtc enabled and it works (tested) and max_prepared_transactions is also set to 100 for postgresql. Is there anything else I sholud configure?

However, we can send you a test build of the provider with 2PC engine disabled (for testing purposes, to avoid the need to configure the provider). Please let us know.

So, please send me this via email: <!-- e --><a href="mailto:michal.milanowski@biatel.com.pl]michal.milanowski@biatel.com.pl[/url]<!-- e -->, I'll try it and let you know how it works

Please Log in or Create an account to join the conversation.

More
13 years 3 months ago #731 by Moderator
If you restarted Postgres after changing configuration, it should have worked. I have repeated all the steps from the Developer's Manual on a test computer and everything worked (Postgres 9, SQL Server 2008 R2 x64, Windows 7). Could the issue be related to Windows Firewall? Have you tried to disable the Firewall?

Anyway, we prepared an evaluation build without calls to XA and sent it to you. Please let us know if you will have questions: support at pgoledb dot com.

Please Log in or Create an account to join the conversation.

More
13 years 3 months ago #732 by ktoss
Thanks, I'm going to test this after new year.

Please Log in or Create an account to join the conversation.

Time to create page: 0.148 seconds
Powered by Kunena Forum