Way to not use a transaction?

  • mmetzger
  • Topic Author
  • Visitor
  • Visitor
13 years 4 months ago #717 by mmetzger
Way to not use a transaction? was created by mmetzger
Hi -

We're transferring a large amount of data but seeing the server eat a huge amount of memory during the transfer. Looking in the profiler, it appears to issue a transaction at the beginning of the transfer. Is there an easy way to disable this and simply execute the command directly?

Thanks!

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #719 by Moderator
Replied by Moderator on topic Re: Way to not use a transaction?
Are you transferring data into the Postgres DB? If that's the case, are you using connection string parameter BULK_METHOD=COPY?

Please Log in or Create an account to join the conversation.

  • mmetzger
  • Topic Author
  • Visitor
  • Visitor
13 years 4 months ago #720 by mmetzger
Replied by mmetzger on topic Re: Way to not use a transaction?
Yes, it's transferring data into postgres. I had tried using the COPY option, but unfortunately postgres does not appear to support the use of BYTEA fields in COPY options (even COPY BINARY) as all my tests came out blank.

Please Log in or Create an account to join the conversation.

More
13 years 3 months ago #726 by Moderator
Replied by Moderator on topic Re: Way to not use a transaction?
Could you send us tables schema and any additional information to help us reproduce the issue with large memory utilization?

We are working on bytea and COPY issue.

Thank you

Please Log in or Create an account to join the conversation.

Time to create page: 0.144 seconds
Powered by Kunena Forum