Disabling PGNP optimizer

More
3 years 10 months ago #10328 by barakp
Hi,
I'm using PGNP to connect to a postgresql DB. In the DB's log I see the following error:
ERROR: relation "pgnp_optimizer" does not exist at character 49
STATEMENT: SELECT OPTIMIZER_ID, HASHTYPE, HASH, FINAL FROM PGNP_OPTIMIZER WHERE ENABLED = 'Y'

I would like to disable the PGNP optimizer as I'm connecting with a read only user to the database.
Please advise how to do so.

Thanks,
Barak

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10333 by Moderator
We added new connection string parameter OPTIMIZER=ON/OFF in build 1.4.0.3200. This is an optional parameter, and the default value is OFF (optimizer is not enabled).

Users who previously used the Optimizer must add the parameter OPTIMIZER=ON to the Extended Properties of the connection string.

Please Log in or Create an account to join the conversation.

Time to create page: 0.123 seconds
Powered by Kunena Forum